Space 1999 Eagle Transporter Forum


Go Back   Space 1999 Eagle Transporter Forum > Deep Space Tracking Station > Breakaway > Blakes 7

Notices

SPONSORED BY
&

Reply Bookmark and Share
 
Thread Tools Display Modes
Old 23-10-2013, 08:23 AM   #1
T.F.U.
Astrophysics Technician
 
T.F.U.'s Avatar
 
Join Date: Dec 2011
Posts: 496
Default Liberator hand blaster noise

In my constant quest for the perfect liberator hand gun - has anyone got a decent digital recording or reconstruction of the sound of the blaster they might like to share.
T.F.U. is off duty   Bookmark and Share Reply With Quote
Old 23-10-2013, 10:29 AM   #2
KevinD
Communications Officer
 
KevinD's Avatar
 
Join Date: Oct 2010
Posts: 1,058
Default

I haven't but it is available on BBC album 'Sci Fi Sound effects' (which was vinyl or cassette), re-released as 'Essential Science Fiction Sound Effects Volume 1' (on CD). These can still be found and may be downloadable for all I know. There are a lot of other B7 sounds on the album, I used it when making Orac but then gave it to a friend who collects B7 merchandise.
KevinD is off duty   Bookmark and Share Reply With Quote
Old 23-10-2013, 12:35 PM   #3
Exterminator
Deputy Commander
 
Exterminator's Avatar
 
Join Date: Nov 2008
Location: Swindon, Wiltshire, where it never rains (ish)
Posts: 872
Default

I've got good samples of the whole album in both WAV and MP3 formats. PM me your email address and I'll send you them both!


Cheers,

Phil
Exterminator is off duty   Bookmark and Share Reply With Quote
Old 03-11-2013, 02:30 PM   #4
T.F.U.
Astrophysics Technician
 
T.F.U.'s Avatar
 
Join Date: Dec 2011
Posts: 496
Default

Can anyone get one of those bloody maplins player sound cards to work... I know I cant arghhh anyone help?
T.F.U. is off duty   Bookmark and Share Reply With Quote
Old 03-11-2013, 03:03 PM   #5
KevinD
Communications Officer
 
KevinD's Avatar
 
Join Date: Oct 2010
Posts: 1,058
Default

I've used several in models with no problem, but I have had a sound to light chaser from them that just wouldn't work. What exactly is it not doing?
KevinD is off duty   Bookmark and Share Reply With Quote

Old 03-11-2013, 05:47 PM   #6
T.F.U.
Astrophysics Technician
 
T.F.U.'s Avatar
 
Join Date: Dec 2011
Posts: 496
Default

No power going through at all exasperating really.
T.F.U. is off duty   Bookmark and Share Reply With Quote
Old 03-11-2013, 06:16 PM   #7
KevinD
Communications Officer
 
KevinD's Avatar
 
Join Date: Oct 2010
Posts: 1,058
Default

No power at all should mean the solder joints to the battery clip are bad or the clip itself is faulty. Have you got a multi meter to check it with or a mains adapter you could use to see if it is a faulty battery clip?
KevinD is off duty   Bookmark and Share Reply With Quote
Old 03-11-2013, 06:34 PM   #8
T.F.U.
Astrophysics Technician
 
T.F.U.'s Avatar
 
Join Date: Dec 2011
Posts: 496
Default

Cheers mate ill check it out.
T.F.U. is off duty   Bookmark and Share Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 04:15 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
This site and contents are copyright Bernard Walsh 2010 all rights reserved, no reproduction of material in any form without written permission email: Bernie.walsh@mac.com