Space 1999 Eagle Transporter Forum


Go Back   Space 1999 Eagle Transporter Forum > Administration Complex > Commander's Office

Notices

SPONSORED BY
&

Reply Bookmark and Share
 
Thread Tools Display Modes
Old 08-06-2017, 08:38 AM   #41
Guyus24
Waste Technician
 
Guyus24's Avatar
 
Join Date: Nov 2016
Location: Australia
Posts: 16
Default

I got another database error this morning. Same one as before.

It's working now. Was I the only one to see the error?
Guyus24 is off duty   Bookmark and Share Reply With Quote
Old 08-06-2017, 02:11 PM   #42
ExcelsiorUK
Alphan
 
Join Date: Jun 2017
Location: Yorkshire, UK
Posts: 5
Default

I was accessing it on Virgin Media and they tried to block you at source - when I ignored it I got a pop up which I suspect would have done something nasty had I not navigated away. Perhaps an issue with one of the ads, but if other ISPs block you I guess it's not going to help things?
ExcelsiorUK is off duty   Bookmark and Share Reply With Quote
Old 05-10-2017, 06:09 PM   #43
KevinD
Communications Officer
 
KevinD's Avatar
 
Join Date: Oct 2010
Posts: 1,058
Default

I am finding the forum incredibly slow (ie several seconds for a letter to appear when you type it). I use my phone but this is the only site that does it. Been like it for a few days.
KevinD is off duty   Bookmark and Share Reply With Quote
Old 05-10-2017, 07:15 PM   #44
Andernut
Waste Technician
 
Andernut's Avatar
 
Join Date: Jan 2009
Location: Australia
Posts: 11
Default

Last two times that I logged on my Avast Antivirus tells me that Threat Has Been Detected!
Andernut is off duty   Bookmark and Share Reply With Quote
Old 06-10-2017, 05:37 AM   #45
hwels
Communications Officer
 
hwels's Avatar
 
Join Date: Oct 2005
Location: Amersfoort, the Netherlands
Posts: 771
Default

And so does Malwarebytes! It reports an outgoing connection to 'coinhive.com' each time I load a page on this website. I don't have this problem on other websites I frequently visit.
hwels is off duty   Bookmark and Share Reply With Quote

Old 06-10-2017, 12:52 PM   #46
msw_1999
Chef
 
Join Date: Sep 2012
Posts: 20
Default

Is there still a problem with images on some threads? --- For example the Thunderbirds fire engine thread does not have its pictures anymore...
msw_1999 is off duty   Bookmark and Share Reply With Quote
Old 09-10-2017, 05:38 AM   #47
Face Ache
Eagle Pilot
 
Face Ache's Avatar
 
Join Date: Mar 2012
Location: Sydney
Posts: 607
Default

I get this.



Naughty.
Face Ache is off duty   Bookmark and Share Reply With Quote
Old 12-10-2017, 01:09 AM   #48
Tech_Designer
Travel Tube Technician
 
Join Date: Oct 2011
Posts: 69
Default

I didn't get any pop-up (probably from ABP) but after I read the last post above, I checked my task manager and my CPU was at 100%. I logged out and killed the tab, my CPU dropped back to normal. It's been fine the last 2 days when I come here.
Tech_Designer is off duty   Bookmark and Share Reply With Quote
Old 12-10-2017, 03:20 PM   #49
KevinD
Communications Officer
 
KevinD's Avatar
 
Join Date: Oct 2010
Posts: 1,058
Default

This site almost freezes my phone now. Takes 10 minutes to make a brief post.
KevinD is off duty   Bookmark and Share Reply With Quote
Old 18-10-2017, 08:37 PM   #50
karr1981
Assistant Commander
 
karr1981's Avatar
 
Join Date: Feb 2010
Posts: 2,202
Default

Hi Guys, I have been investigating this issue and am working with our server hosts to resolve any issues, ill update you asap once I know more.
__________________
The Hobby Shack, an online hobby retailer in the UK aiming to bring you quality products covering a range of hobby subjects


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
karr1981 is off duty   Bookmark and Share Reply With Quote

Old 20-10-2017, 05:25 PM   #51
Boldman
Eagle Pilot
 
Boldman's Avatar
 
Join Date: Apr 2011
Location: Berkshire, UK
Posts: 525
Default

This site now consume 99% CPU resources when on any page - this means I am no longer visiting this site as it stops my PC doing ANYTHING else.

You have some runaway javascript processes on this page that are trying to encrypt or decrypt something and it seems to be stuck in a loop. From the performance analyser in Chrome, it looks like you have a recurring timer that has been triggered by your Google Syndication ads that fires every 0.2 seconds that seems to be swallowing up lots of CPU cycles, then every 1.5 seconds another event fires which does more stuff. In between there look to be other timers firing every 0.2 seconds to do other stuff. Frankly, its a bloody mess!

You also have a major JS problem with the way you invoke Google Analytics that the browser is flagging as unsafe and potential cross-site scripting - that'll be why people are seeing popups.

My advice to you is strip out ALL the crud from the site - analytics, ads etc and get back to the bare-bones forum and then slowly re-add things back to see what breaks. Check the newest versions of the Google ads gumpf as well and use them rather than what you are currently trying to use as I think that is what is causing the problems

Just to note I've been a website developer for 20 years and a software developer for 35 years.
Boldman is off duty   Bookmark and Share Reply With Quote
Old 20-10-2017, 05:33 PM   #52
Boldman
Eagle Pilot
 
Boldman's Avatar
 
Join Date: Apr 2011
Location: Berkshire, UK
Posts: 525
Default

Okay by using my adblocker and privacy badger extensions on most aggressive blocking, that has eliminated the 99% CPU loading by killing the load of all the crud from:

addthis
coinhive
google-analytics
googlesydication

that were causing all the problems. The site is now usable again so you really need to sort out your adverts, its causing all the grief.

Hang abouts... coinhive? WTF is that?

https://coinhive.com/

"Monetize Your Business With Your Users' CPU Power"

Er excuse me - you are mining bitcoin using my PC CPU on your website?

Last edited by Boldman; 20-10-2017 at 06:43 PM.
Boldman is off duty   Bookmark and Share Reply With Quote
Old 20-10-2017, 06:13 PM   #53
karr1981
Assistant Commander
 
karr1981's Avatar
 
Join Date: Feb 2010
Posts: 2,202
Default

Hi Everyone,

I have finished resolving the issues, it appears an exploit was found on an addon used by ourselves and many other vbulletin 3/x forums (an addon we use to handle the User albums) which had not been properly updated by its creator.

I have worked with our server host and removed the offending exploit from the site and put in a block to stop this happening again.

Mty apologies it took longer than i would have like to resolve this, but initially i ws unable to spot the issue as my browser runs Ad Block Plus which was blocking the exploit as it is triggered when the page loads an invisible advert, I can highly recommend Ad Block Plus to anyone using Chrome or Firefox (im unsure but there is probably similar for other browsers but unsure if as powerful

Thank you to everyone who posted here or messaged the site to make us aware of the issues.

Chris
__________________
The Hobby Shack, an online hobby retailer in the UK aiming to bring you quality products covering a range of hobby subjects


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
karr1981 is off duty   Bookmark and Share Reply With Quote
Old 20-10-2017, 06:16 PM   #54
karr1981
Assistant Commander
 
karr1981's Avatar
 
Join Date: Feb 2010
Posts: 2,202
Default

Hi Boldman

Yes the exploit was this coinhive thing, the others in your list are just part of our reporting and should not impact your performance now the exploit has been removed, incase any concern i have put in a little identification below for the others

Quote:
Originally Posted by Boldman View Post
Okay by using my adblocker and privacy badger extensions on most aggressive blocking, that has eliminated the 99% CPU loading by killing the load of all the crud from:

addthis - provides the share buttons in posts
coinhive - offending exploit now from the forum
google-analytics - Statistical data gathering to help manage site costs etc
googlesyndication - helps with the sharing of forum posts and visibility in google searches

that were causing all the problems. The site is now usable again so you really need to sort out your adverts, its causing all the grief.

Hang abouts... coinhive? WTF is that?

https://coinhive.com/

"Monetize Your Business With Your Users' CPU Power"

Er excuse me - you are mining bitcoin using my PC CPU on your website?

Not anymore you are not - goodbye!
__________________
The Hobby Shack, an online hobby retailer in the UK aiming to bring you quality products covering a range of hobby subjects


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
karr1981 is off duty   Bookmark and Share Reply With Quote
Old 20-10-2017, 06:43 PM   #55
Boldman
Eagle Pilot
 
Boldman's Avatar
 
Join Date: Apr 2011
Location: Berkshire, UK
Posts: 525
Default

Thanks Chris, glad it has been sorted
Boldman is off duty   Bookmark and Share Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 08:12 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
This site and contents are copyright Bernard Walsh 2010 all rights reserved, no reproduction of material in any form without written permission email: Bernie.walsh@mac.com