Space 1999 Eagle Transporter Forum

Space 1999 Eagle Transporter Forum (http://www.eagletransporter.com/forum/index.php)
-   Commander's Office (http://www.eagletransporter.com/forum/forumdisplay.php?f=10)
-   -   Technical issues (http://www.eagletransporter.com/forum/showthread.php?t=162105)

Guyus24 08-06-2017 08:38 AM

I got another database error this morning. Same one as before.

It's working now. Was I the only one to see the error?

ExcelsiorUK 08-06-2017 02:11 PM

I was accessing it on Virgin Media and they tried to block you at source - when I ignored it I got a pop up which I suspect would have done something nasty had I not navigated away. Perhaps an issue with one of the ads, but if other ISPs block you I guess it's not going to help things?

KevinD 05-10-2017 06:09 PM

I am finding the forum incredibly slow (ie several seconds for a letter to appear when you type it). I use my phone but this is the only site that does it. Been like it for a few days.

Andernut 05-10-2017 07:15 PM

Last two times that I logged on my Avast Antivirus tells me that Threat Has Been Detected!

hwels 06-10-2017 05:37 AM

And so does Malwarebytes! It reports an outgoing connection to 'coinhive.com' each time I load a page on this website. I don't have this problem on other websites I frequently visit.

msw_1999 06-10-2017 12:52 PM

Is there still a problem with images on some threads? --- For example the Thunderbirds fire engine thread does not have its pictures anymore...

Face Ache 09-10-2017 05:38 AM

I get this.

https://i.imgur.com/qsUZwit.jpg

Naughty.

Tech_Designer 12-10-2017 01:09 AM

I didn't get any pop-up (probably from ABP) but after I read the last post above, I checked my task manager and my CPU was at 100%. I logged out and killed the tab, my CPU dropped back to normal. It's been fine the last 2 days when I come here.

KevinD 12-10-2017 03:20 PM

This site almost freezes my phone now. Takes 10 minutes to make a brief post.

karr1981 18-10-2017 08:37 PM

Hi Guys, I have been investigating this issue and am working with our server hosts to resolve any issues, ill update you asap once I know more.

Boldman 20-10-2017 05:25 PM

This site now consume 99% CPU resources when on any page - this means I am no longer visiting this site as it stops my PC doing ANYTHING else.

You have some runaway javascript processes on this page that are trying to encrypt or decrypt something and it seems to be stuck in a loop. From the performance analyser in Chrome, it looks like you have a recurring timer that has been triggered by your Google Syndication ads that fires every 0.2 seconds that seems to be swallowing up lots of CPU cycles, then every 1.5 seconds another event fires which does more stuff. In between there look to be other timers firing every 0.2 seconds to do other stuff. Frankly, its a bloody mess! :)

You also have a major JS problem with the way you invoke Google Analytics that the browser is flagging as unsafe and potential cross-site scripting - that'll be why people are seeing popups.

My advice to you is strip out ALL the crud from the site - analytics, ads etc and get back to the bare-bones forum and then slowly re-add things back to see what breaks. Check the newest versions of the Google ads gumpf as well and use them rather than what you are currently trying to use as I think that is what is causing the problems

Just to note I've been a website developer for 20 years and a software developer for 35 years.

Boldman 20-10-2017 05:33 PM

Okay by using my adblocker and privacy badger extensions on most aggressive blocking, that has eliminated the 99% CPU loading by killing the load of all the crud from:

addthis
coinhive
google-analytics
googlesydication

that were causing all the problems. The site is now usable again so you really need to sort out your adverts, its causing all the grief.

Hang abouts... coinhive? WTF is that?

https://coinhive.com/

"Monetize Your Business With Your Users' CPU Power"

Er excuse me - you are mining bitcoin using my PC CPU on your website?

karr1981 20-10-2017 06:13 PM

Hi Everyone,

I have finished resolving the issues, it appears an exploit was found on an addon used by ourselves and many other vbulletin 3/x forums (an addon we use to handle the User albums) which had not been properly updated by its creator.

I have worked with our server host and removed the offending exploit from the site and put in a block to stop this happening again.

Mty apologies it took longer than i would have like to resolve this, but initially i ws unable to spot the issue as my browser runs Ad Block Plus which was blocking the exploit as it is triggered when the page loads an invisible advert, I can highly recommend Ad Block Plus to anyone using Chrome or Firefox (im unsure but there is probably similar for other browsers but unsure if as powerful

Thank you to everyone who posted here or messaged the site to make us aware of the issues.

Chris

karr1981 20-10-2017 06:16 PM

Hi Boldman

Yes the exploit was this coinhive thing, the others in your list are just part of our reporting and should not impact your performance now the exploit has been removed, incase any concern i have put in a little identification below for the others

Quote:

Originally Posted by Boldman (Post 408900)
Okay by using my adblocker and privacy badger extensions on most aggressive blocking, that has eliminated the 99% CPU loading by killing the load of all the crud from:

addthis - provides the share buttons in posts
coinhive - offending exploit now from the forum
google-analytics - Statistical data gathering to help manage site costs etc
googlesyndication - helps with the sharing of forum posts and visibility in google searches

that were causing all the problems. The site is now usable again so you really need to sort out your adverts, its causing all the grief.

Hang abouts... coinhive? WTF is that?

https://coinhive.com/

"Monetize Your Business With Your Users' CPU Power"

Er excuse me - you are mining bitcoin using my PC CPU on your website?

Not anymore you are not - goodbye!


Boldman 20-10-2017 06:43 PM

Thanks Chris, glad it has been sorted :)


All times are GMT. The time now is 07:06 PM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
This site and contents are copyright Bernard Walsh 2010 all rights reserved, no reproduction of material in any form without written permission email: Bernie.walsh@mac.com